Back to overview
Downtime

Tommy's Hosting is Down

May 25, 2026 at 3:10am UTC
Affected services
panel.tommyfr.xyz

Resolved
May 25, 2026 at 3:22am UTC

Everything is back online.

Updated
May 25, 2026 at 3:17am UTC

We have identified the issue. We are doing a internet reset at the moment and all services affected should be on within the next 5-10 minutes.

Created
May 25, 2026 at 3:10am UTC

We are aware of the current issues with https://panel.tommyfr.xyz & our Apex node. We are currently working on a fix.